Eroare WordPress: SSL certificate problem


#1

Am actualizat recent de la o versiune veche de WordPress la ultima versiune si s-a afisat pe ecran foarte frumos o eroare:

SSL certificate problem: unable to get local issuer certificate

A little help? :crazy_face:


#2

WordPress verifică certificatul autorității de certificare (CA certificate) începând de la versiunea 3.7 și ai primit eroarea de mai sus pentru că nu se poate conecta printr-o conexiunea sigură. Certificatul îl găsești aici:

/wp-includes/certificates/bundle.crt

Ca să faci actualizarea fără probleme trebuie să dezactivezi verificarea certificatului SSL și poți face asta adaugând două linii de cod în wp-config.php:

add_filter('https_ssl_verify', '__return_false');
add_filter('https_local_ssl_verify', '__return_false');

Salvează fișierul și te poți ocupa de actualizare dar îți recomand următori pași:

  • back-up înainte de actualizare;
  • actualizare plugin-uri;
  • actualizare temă;
  • actualizare WordPress;

În mod normal totul ar trebui să fie actualizat cu succes. :smile:


#3

M-ai salvat! Mersi. :+1: